Installation

Currently ct4l-lib is in its first steps. The only way to install it is by compilling the source code using cmake in the usual way. The following instructions were executed only in Linux-based operational systems for now.

Pre-requisites

The non-development requirements are:
  1. gcc with C++17 support

  2. cmake

  3. flex

  4. bison

For developers, the following packages are also needed:
  1. gcovr

  2. sphinx

  3. breathe

Building

  1. Clone the project repository:

    git clone https://gitlab.com/ct4l/ct4l-lib.git
    
  2. Execute the following commands:

    cd ct4l-lib
    cmake -Bbuild -Ssources
    cd build
    make